Please help with my coil

An alchemy of sparks, copper wire and earth

Moderators: User administrators, Moderators

Locked
User avatar
paulandchez
Posts: 186
Joined: 25 Mar 2013, 23:29
80-90 Mem No: 12181
Location: Preston, Lancashire

Please help with my coil

Post by paulandchez »

This is my current coil. I've had sudden starting issues yesterday. Been running fine all week and then refuses to start. I have already put in new ignition switch, starter motor and oilite bush and van has been running great. All of a sudden, engine turns but refuses to fire. Checked fuel, that's good.
Checked HT leads and had a dodgy king lead so made new leads up, checked resistance and all good. Went to start and it fired up but clearly not on all cylinders and wouldn't stay running at all. Was very rough.

Checked the coil resistances and I get 1.4 ohms between 1 and 15, and 4.75k ohms between 1 and 4. I think the coil for my engine should be 0.52-0.76 and 2.4k-3.5k ohms. As you can see my coil isn't one like Bosch that I'd recognise. So can someone please tell me if I'm right in my numbers above and therefore my coil is knacked, and also advise which one to order.

Image

Image

Thanks

Paul
T25 Westfalia 2.0l Aircooled 1980 in a nice beige colour with a bit of antique steel thrown in

User avatar
itchyfeet
Posts: 12387
Joined: 23 Jul 2007, 17:24
80-90 Mem No: 12733
Location: South Hampshire

Re: Please help with my coil

Post by itchyfeet »

Looks like a generic coil, may not be ideal but if it was working more than likely something else like leads cap rotor arm, earths 12v ignition pos connection etc
Last edited by itchyfeet on 23 Jul 2014, 20:55, edited 1 time in total.
1988 DG WBX LPG Tin Top
1989 DJ digijet WBX Holdsworth Villa 3 Pop Top
itchylinks

User avatar
paulandchez
Posts: 186
Joined: 25 Mar 2013, 23:29
80-90 Mem No: 12181
Location: Preston, Lancashire

Re: Please help with my coil

Post by paulandchez »

I'll double check leads again just incase. Regarding the earths, I was going to add another due to the gearbox one being 34 now....but after reading wiki etc, it doesn't actually say where I could add another for the engine/gearbox. Any suggestions?
T25 Westfalia 2.0l Aircooled 1980 in a nice beige colour with a bit of antique steel thrown in

User avatar
paulandchez
Posts: 186
Joined: 25 Mar 2013, 23:29
80-90 Mem No: 12181
Location: Preston, Lancashire

Re: Please help with my coil

Post by paulandchez »

The only thing I did between it working and not was change the steering wheel.....but surely that can't affect it. I put a caravelle one on to give me a little more leg room
T25 Westfalia 2.0l Aircooled 1980 in a nice beige colour with a bit of antique steel thrown in

User avatar
itchyfeet
Posts: 12387
Joined: 23 Jul 2007, 17:24
80-90 Mem No: 12733
Location: South Hampshire

Re: Please help with my coil

Post by itchyfeet »

Pull plugs out and lay on engine crank and look for good sparks
If it cranks main starter earth is ok but add a smaller one near the dizzy to the body by the coil
1988 DG WBX LPG Tin Top
1989 DJ digijet WBX Holdsworth Villa 3 Pop Top
itchylinks

User avatar
paulandchez
Posts: 186
Joined: 25 Mar 2013, 23:29
80-90 Mem No: 12181
Location: Preston, Lancashire

Re: Please help with my coil

Post by paulandchez »

My coil currently sits on the tinware but was gonna move it to the wall by the ignition module. There is an earth on the engine next to the dizzy, so if I connect that to body that should be ok yeah?
T25 Westfalia 2.0l Aircooled 1980 in a nice beige colour with a bit of antique steel thrown in

User avatar
bigherb
Posts: 2417
Joined: 27 Mar 2008, 13:50
80-90 Mem No: 5789
Location: West Kent

Re: Please help with my coil

Post by bigherb »

That is a F0rd coil for points ignition someone has adapted, but it still should work as itchy says could well be something else like HT leads, plug caps etc.
1982 Camper 1970 1500 Beetle Various Skoda's, Ariel Arrow

User avatar
marlinowner
Posts: 1528
Joined: 28 Jan 2014, 12:02
80-90 Mem No: 13646
Location: Scottish Borders

Re: Please help with my coil

Post by marlinowner »

Sounds like the fault has changed from not starting at all to misfiring when you changed the HT leads. Either the new leads are faulty or in the wrong order, or there is a problem such as distributor cap not properly seated.
1993 SA VW T25/T3 2.5i Microbus/homebrew camper
1981/1968 Marlin Kitcar TR6 Engine

Locked