Indicator tell tale lamp not working

An alchemy of sparks, copper wire and earth

Moderators: Moderators, User administrators

Post Reply
morzov
Posts: 103
Joined: 26 Aug 2007, 11:34
80-90 Mem No: 4503

Indicator tell tale lamp not working

Post by morzov »

Have got an MOT coming up on my 1982 T25 2 litre air cooled.

The direction indicator tell tale light on the dash is not working although the indicators actually work and you can hear the tell tale.

Not entirely sure whether this is an MOT fail or not but would like to put it right in case it is and anyway its useful in case forget to cancel indicators.

Pretty sure this has happened before then it suddenly start works again so I'm hoping it is something simple. 

Be grateful for any suggestions.

User avatar
Robsey
Posts: 310
Joined: 19 May 2012, 20:45
80-90 Mem No: 11137
Location: East Manchester

Re: Indicator tell tale lamp not working

Post by Robsey »

The obvious thought is the connector or the foil circuit board.

Unlikely it would be a faulty LED.
They do not 'blow' as readily as a normal bulb would.
But you could check that it is still securely fitted.

So my first thought would be to ensure that the main 14 pin connector is fully seated onto the foil.

Beyond that, you are looking at a faulty foil.
Which would either need carefull repairing or replacing.
1983 Tin Top with a poorly DF and 4 speed DT box.
Soon to have a whizzy 1987 DJ.

morzov
Posts: 103
Joined: 26 Aug 2007, 11:34
80-90 Mem No: 4503

Re: Indicator tell tale lamp not working

Post by morzov »

Nice One. Thanks.

Went out and fiddled with the connector and sprayed a bit of WD40 and with a bit more wiggling it works. Hopefully it will last.

Dash binnacle in serious need of repair though - just one retaining lug still intact!

Post Reply