Wiper headlight issues!

An alchemy of sparks, copper wire and earth

Moderators: User administrators, Moderators

Post Reply
Danskip77
Posts: 5
Joined: 01 Feb 2021, 20:03
80-90 Mem No: 1

Wiper headlight issues!

Post by Danskip77 »

Good evening all, hope everyone's well. I have a 85 t25,and jusr had a new gremlin pop up. When I have ignition on, headlamps and wipers are fine. As soon as engine is on. I have drivers sidelamps7and no wipers? If I click to full beam then wipers come on! Any advice greatly appreciated. Tia!

Danskip77
Posts: 5
Joined: 01 Feb 2021, 20:03
80-90 Mem No: 1

Re: Wiper headlight issues!

Post by Danskip77 »

Image

User avatar
slowcoach
Posts: 1258
Joined: 06 May 2010, 10:23
80-90 Mem No: 8892
Location: West Yorkshire
Contact:

Re: Wiper headlight issues!

Post by slowcoach »

I'd guess that is a grounding issue- once the engine is running a new path is found or lost to ground and bypassing what you need.

Check out the 'earth crowns' (search for a picture) , just above and behind the glovebox to make sure they are clean and all connected up. Common problem for electrical gremlins ;)


Also check back of the light switch in binnacle !
===================
1984 TRAKKA Conversion Subaru EJ20 5 Speed

Danskip77
Posts: 5
Joined: 01 Feb 2021, 20:03
80-90 Mem No: 1

Re: Wiper headlight issues!

Post by Danskip77 »

Hi slow coach, I, finally had some time to have a look and do as suggested. Still not working. I've cleaned the crowns and all connections, also had the binnacle switch out and cleaned all that up but no joy! Im a completely amateur and trying to learn as I go, you have any other suggestions for me to try?! Tia 🙏

User avatar
Oldiebut goodie
Posts: 6627
Joined: 18 Apr 2008, 01:19
80-90 Mem No: 11135
Location: Eastern Angle

Re: Wiper headlight issues!

Post by Oldiebut goodie »

^^^^WHS^^^^
Make sure you remove the crowns as you tend to get corrosion underneath due to the inevitable windscreen leak.
1.6D 2019 VW T-Cross
200hp T6
1̶Y̶ ̶1̶9̶8̶7̶ ̶H̶i̶-̶t̶o̶p̶ ̶C̶a̶r̶a̶v̶e̶l̶l̶e̶
5̶0̶8̶d̶ ̶M̶e̶r̶c̶

User avatar
Mocki
Membership Admin
Posts: 15639
Joined: 29 Sep 2005, 09:27
80-90 Mem No: 428
Location: Mansfield tel/txt 07947137911
Contact:

Re: Wiper headlight issues!

Post by Mocki »

I would be looking at the "x" relay and it’s connections , make sure they are not corroded and that the earth to it is good and clean at both ends , as has been said above 
the "x" relay removes power from everything apart from the ignition circuit whilst you crank the engine , apart from side lights and main beam and brake lights .
wipers , heater fans , headlights are all disconnected , so if that circuit has a fault , they will all be dead 
Steve
tel / txt 07947137911
Image
just one shade of very fast grey
________________

1989 2.1LpgWBX HiTop Leisuredrive Camper

Danskip77
Posts: 5
Joined: 01 Feb 2021, 20:03
80-90 Mem No: 1

Re: Wiper headlight issues!

Post by Danskip77 »

Okay checked and cleaned all these. After further inspection on t'interweb it seems I need a new ignition switch. Have one ordered hopefully this will be it!

Post Reply