Speedometer problem

An alchemy of sparks, copper wire and earth

Moderators: Moderators, User administrators

TONYT25T25
Posts: 881
Joined: 16 Sep 2013, 17:19
80-90 Mem No: 13596
Location: Hampshire

Speedometer problem

Post by TONYT25T25 »

Speedometer playing up again, I have unclipped it from behind the binnacle and put a few drops of 3 in 1 oil down it, but it is still not right, sometimes it rises in excess of what the speed should be sometimes sticks at a speed even when van has stopped, reversing resets the needle and after a short time when parked up it also drops to where it should sit, MOT soon so concerned it would be picked up as a failure.  Not sure if lack of use is the problem or is it the cable or unit. Wiggling the cable sometimes when driving moves it but still not satisfactory, any advice would be welcomed.
1984 Campervan 1.9DG Petrol WBX

MidLifeCrisis
Posts: 558
Joined: 20 Nov 2011, 19:07
80-90 Mem No: 10519
Location: Bagshot, Surrey

Re: Speedometer problem

Post by MidLifeCrisis »

I would suggest that if the speedo is sticking at a speed even when the vehicle is stationary then that points to a problem with the speedo unit (rather than the cable that goes to the wheel)

The below website has a nice explanation of how a mechanical speedo works - and suggests that the speedcup/spring/needle is somehow sticking - not sure how easy it is to fix - that unit is quite sealed up to prevent mileage tampering I guess - might be easier to look for a replacement;

https://www.explainthatstuff.com/how-sp ... works.html

I had similar experience which only seemed to occur in cold weather ! Which I assumed was something related to oils getting more sticky or something;

FYI - looks like an ‘impaired operation’ speedo is an MOT minor, and a ‘not working’ speedo is a major - so might depend on garages interpretation?!?
1987 Westfalia Van, Petrol 2.0 AGG

User avatar
Mocki
Membership Admin
Posts: 15923
Joined: 29 Sep 2005, 09:27
80-90 Mem No: 428
Location: Mansfield tel/txt 07947137911
Contact:

Re: Speedometer problem

Post by Mocki »

I am pretty sure they do not test ( nor can they ) the speedometer for MOT .

Sounds to me like it’s the actual dash item rather than the cable in this instance from your description
Maybe worth very gently taking it apart and having a look see .
Steve
tel / txt O7947-137911
👀
________________

1989 2.1LpgWBX HiTop Leisuredrive Camper
1988 2.1 Caravelle TS TinTop Camper 
 

TONYT25T25
Posts: 881
Joined: 16 Sep 2013, 17:19
80-90 Mem No: 13596
Location: Hampshire

Re: Speedometer problem

Post by TONYT25T25 »

Thanks for replies, mine also plays up in the colder months as it appears ok in the summer, just wondering to narrow down area if it is possible to stick something behind the speedo unit to simulate rotation of the wheel to see if it rises and drops, after reading the wiki which pointed to the nearside wheel as a possible area to look at.  Found this video on you tube which I may also pursue, or leave it until after the MOT and see what happens then to give me more time.  https://www.youtube.com/watch?v=_pDzWH0GebQ
1984 Campervan 1.9DG Petrol WBX

TONYT25T25
Posts: 881
Joined: 16 Sep 2013, 17:19
80-90 Mem No: 13596
Location: Hampshire

Re: Speedometer problem

Post by TONYT25T25 »

Temporary fix but not solution, I have managed to get it working properly of sorts by placing a piece of high density foam between the cable and where it passes alongside the brake servo drum this allows it to operate again without stressing either part.  Will leave this in place for time being until I can suss out if it is the cable itself having to much of a bend in it or the speedo, not ideal but sufficient for now I think.
1984 Campervan 1.9DG Petrol WBX

User avatar
AngeloEvs
Posts: 1123
Joined: 22 Nov 2007, 19:22
80-90 Mem No: 4709
Location: Upwell, Norfolk

Re: Speedometer problem

Post by AngeloEvs »

With the vehicle stationary, the needle can only stick if the shaft that the needle sits on is somehow interfered with. There is a coil spring that should be returning the shaft and needle to 0.

The needle shaft is not physically connected to the actual speedo drive mechanism as it uses induction to rotate but if the drive unit is not secure then it could cause the shaft to be off centre and cause it to stick. Putting pressure on the cable to be in a particular position could be putting the drive unit into the correct position which is why it now functions as it should.

I would remove the speedo, rotate the needle and check it returns to 0 freely, also checking the securing screws that hold the drive unit are tight.
1987 DG Karisma LPG with remodelled interior

TONYT25T25
Posts: 881
Joined: 16 Sep 2013, 17:19
80-90 Mem No: 13596
Location: Hampshire

Re: Speedometer problem

Post by TONYT25T25 »

Thanks for in depth explanation, I wonder if removing the speedo cable from the back of the unit and replacing it has somehow misaligned something, where are the securing screws that hold the drive unit located. Not sure what or where the drive unit is??
1984 Campervan 1.9DG Petrol WBX

User avatar
AngeloEvs
Posts: 1123
Joined: 22 Nov 2007, 19:22
80-90 Mem No: 4709
Location: Upwell, Norfolk

Re: Speedometer problem

Post by AngeloEvs »

Sorry, I should have added that the securing screws that hold the speedo drive machanism can only be accessed by stripping the speedo down (removing the needle, fascia plate, spring and odometer assembly).
1987 DG Karisma LPG with remodelled interior

TONYT25T25
Posts: 881
Joined: 16 Sep 2013, 17:19
80-90 Mem No: 13596
Location: Hampshire

Re: Speedometer problem

Post by TONYT25T25 »

Thanks, may have a go at that later on, in meantime hope existing repair lasts.
1984 Campervan 1.9DG Petrol WBX

TONYT25T25
Posts: 881
Joined: 16 Sep 2013, 17:19
80-90 Mem No: 13596
Location: Hampshire

Re: Speedometer problem

Post by TONYT25T25 »

Seems like only yesterday I was talking about this, but the speedo over the last couple of weeks has started to work properly again, this appears to be a Winter problem as previously mentioned and now due to the warmer weather is operating as it should be. 
1984 Campervan 1.9DG Petrol WBX

jgrace2008
Posts: 7
Joined: 12 Mar 2020, 22:42
80-90 Mem No: 0

Re: Speedometer problem

Post by jgrace2008 »

Hi Folks, first time posting. I was having the dreaded noisy Speedo, got unbearably loud so decided to take it apart. Stripped it down completely, removing the 3 (brass) screws behind the odometer which allows you the to completely remove the odometer.
ImageImage
The shaft with the magnet, which the Speedo cable adjoins can then be removed.
Image
It’s this that causes the noise, as there was play in mine. Some really gentle tapping with a hammer, whilst having the piece with magnet wheel side down on a vice, took the play out of the shaft.
ImageImage
Happy day’s!! Not quite, broke the pin that connects the Speedo needle while reassembling. I now don’t have a working Speedo, but on the positive side I don’t have any noise coming from the unit when Speedo cable re-installed. I tried to attach pictures but couldn’t figure out how to do it (using iPhone??). Anyway, I know Speedo’s are like hens teeth but would anyone have a spare one I could buy? It’s the late version with the 6 electrical pins at the back.
Last edited by jgrace2008 on 21 Apr 2021, 10:14, edited 1 time in total.
1987 T25 (1.9 TD AAZ)
“Every time I fix one thing, I break 2 more - lifetime hobby!”

TONYT25T25
Posts: 881
Joined: 16 Sep 2013, 17:19
80-90 Mem No: 13596
Location: Hampshire

Re: Speedometer problem

Post by TONYT25T25 »

Fortunately did not have to go to that extent on mine.  Posting photos is as follows.

Image

Also worth adding details of vehicle type in your signature block to aid assistance.
1984 Campervan 1.9DG Petrol WBX

jgrace2008
Posts: 7
Joined: 12 Mar 2020, 22:42
80-90 Mem No: 0

Re: Speedometer problem

Post by jgrace2008 »

Thanks Tony, I have added the photos there now
1987 T25 (1.9 TD AAZ)
“Every time I fix one thing, I break 2 more - lifetime hobby!”

TONYT25T25
Posts: 881
Joined: 16 Sep 2013, 17:19
80-90 Mem No: 13596
Location: Hampshire

Re: Speedometer problem

Post by TONYT25T25 »

Have you tried posting in the Wanted section of the forum, as it maybe missed in this one.
1984 Campervan 1.9DG Petrol WBX

jgrace2008
Posts: 7
Joined: 12 Mar 2020, 22:42
80-90 Mem No: 0

Re: Speedometer problem

Post by jgrace2008 »

I put a post in the wanted section earlier, they seem to be like hens teeth. Fortunately it passed its NCT (MOT) recently so I have some time to source one
1987 T25 (1.9 TD AAZ)
“Every time I fix one thing, I break 2 more - lifetime hobby!”

Post Reply