Strange ignition problem

Big lumps of metals and spanners. Including servicing and fluids.

Moderators: Moderators, User administrators

Post Reply
User avatar
mickeyflyn
Posts: 276
Joined: 04 Mar 2012, 17:42
80-90 Mem No: 10871
Location: newport south wales

Strange ignition problem

Post by mickeyflyn »

1983 1.9 df petrol . Engine developed a misfire on the fuel carriageway then cut out , restarted in the layby but would only idle on what sounded like 2 cylinders and would not rev .
At home I checked fuel filter, pump , all good
Checked for a spark at the plugs which is when I discovered that I get a single spark at the plug when ignition is turned on but no spark when cranking .
Turned ignition again and a single spark , no spark when cranking .
Changed the coil as I had a brand new one , changed distributor cap ,checked earths and still the same spark at the plug on turning ignition on but nothing when cranking . I'm stumped! Any ideas please ?
1.9df petrol water cooled 1982 built registered 84 ,
If it aint broke don`t fix it !

User avatar
Aidan
Trader
Posts: 5425
Joined: 11 Oct 2005, 19:21
80-90 Mem No: 742
Location: Llanfyllin, mid Wales : )
Contact:

Re: Strange ignition problem

Post by Aidan »

TCi failure or hall signal issue ?

User avatar
mickeyflyn
Posts: 276
Joined: 04 Mar 2012, 17:42
80-90 Mem No: 10871
Location: newport south wales

Re: Strange ignition problem

Post by mickeyflyn »

I'm thinking ignition module so ordered one from Brickwerks.
Hall sender will be my next thing .
1.9df petrol water cooled 1982 built registered 84 ,
If it aint broke don`t fix it !

User avatar
bigherb
Posts: 2482
Joined: 27 Mar 2008, 13:50
80-90 Mem No: 5789
Location: West Kent

Re: Strange ignition problem

Post by bigherb »

Check the distributor rotor is actually turning when you crank the engine.
1982 Camper 1970 1500 Beetle Various Skoda's, Ariel Arrow

User avatar
mickeyflyn
Posts: 276
Joined: 04 Mar 2012, 17:42
80-90 Mem No: 10871
Location: newport south wales

Re: Strange ignition problem

Post by mickeyflyn »

Will do in the am , thanks for that as it would have never occurred to me.
1.9df petrol water cooled 1982 built registered 84 ,
If it aint broke don`t fix it !

User avatar
ajsimmo
Trader
Posts: 2214
Joined: 23 Mar 2009, 14:06
80-90 Mem No: 6542
Location: Isle of Arran
Contact:

Re: Strange ignition problem

Post by ajsimmo »

Sounds like dizzy may have lifted slightly and come out of mesh with the drive gear, so either not turning, or spark timing is now out. If it's this, one fix is to take out dizzy drive and add an extra shim washer underneath (should be 2, add a 3rd).
Or Ignition switch losing 12v feed to coil when in cranking position. Test by putting separate power to coil direct from battery and then try to start. (There's a convenient live post in the top right corner of the black box.)

Sent from my ONEPLUS A3003 using Tapatalk


The Campershack - (website paused)
WBX Rebuilds & Upgrades from the beautiful Isle of Arran

User avatar
mickeyflyn
Posts: 276
Joined: 04 Mar 2012, 17:42
80-90 Mem No: 10871
Location: newport south wales

Re: Strange ignition problem

Post by mickeyflyn »

Thanks guys I'll check this evening as I have an early finish today.
1.9df petrol water cooled 1982 built registered 84 ,
If it aint broke don`t fix it !

User avatar
mickeyflyn
Posts: 276
Joined: 04 Mar 2012, 17:42
80-90 Mem No: 10871
Location: newport south wales

Re: Strange ignition problem

Post by mickeyflyn »

Problem solved ! It was the ignition control module, new one from Brickwerks although a little expensive compared to others.
Fitted it just now straight from work and first turn of the key buzz fired up and idling lovely .
Thanks again for the contributions guys.
1.9df petrol water cooled 1982 built registered 84 ,
If it aint broke don`t fix it !

User avatar
Aidan
Trader
Posts: 5425
Joined: 11 Oct 2005, 19:21
80-90 Mem No: 742
Location: Llanfyllin, mid Wales : )
Contact:

Re: Strange ignition problem

Post by Aidan »

:ok
TCi typical fault

Post Reply