Poorly Camper

Big lumps of metals and spanners.

Moderators: User administrators, Moderators

Locked
kev706
Posts: 27
Joined: 20 Sep 2008, 14:07
Location: Hampshire

Poorly Camper

Post by kev706 »

Hi I am putting this out to forum members for some clues as to what's wrong with my sisters camper.

She has a 19DG 1987 with an intermittent problem. Runs great for a while then when warm looses power and stops, will start again on tick-over but wont rev when accelerator pressed.
Each time breakdown company blow out carb and all fine for a while then it stops again, all fuel filters are clean including one inside inlet pipe of carb.

She is on holiday in south Devon (Salcombe) at the moment and will need to be recovered on Monday to Hampshire if the issue cant be sorted.

Please any advice to try or give to breakdown guy when she next calls them out.

Many Thanks. Kev

User avatar
ghost123uk
Posts: 6837
Joined: 10 Mar 2006, 10:15
80-90 Mem No: 2585
Location: John in Malpas, in the very S. W. part of Cheshire.
Contact:

Re: Poorly Camper

Post by ghost123uk »

1) Remove feed pipe from carb. Put it in a small plastic pop bottle. Start engine up (it will run on what is in the carb). Watch for a healthy steam of fuel going into the pop bottle. NOTE = observe fire precautions whilst doing this. Is there a healthy stream of petrol ? If not, suspect blockages or fuel pump (and it's push rod, it should be 100mm long, they can wear down)

2) Test the coil - see how to HERE or replace coil with either a known good one or a new one (note use the correct one like THIS from Brickwerks. When "on there way out" a coil can start to fail when it gets warm.

3) Replace ignition amp with either a known good one or a new one, like THIS again from Brickwerks. When "on there way out" they too have been known to start to fail when they get warm.

Let us know how you get on, if ness we can go further ;)
Got a new van, but it's a 165bhp T4 [shock horror] Accurate LPG Station map here

mike9009
Posts: 122
Joined: 25 Apr 2012, 19:13
80-90 Mem No: 0

Re: Poorly Camper

Post by mike9009 »

Hi

I had similar symptoms a few weeks ago. My van would travel for several miles then cut out. I could leave it for ten minutes and it would start again - but often lacking power. The distance I could travel was getting shorter and shorter before stopping. It was back firing every now and again too.

A simple check for the coil (I was told) was to check if it was hot after the van stops. Mine was stone cold when the van was stopping.

So I changed the ignition amplifier (two screws and a clip) - which has solved my issues.

When mine cut out, it did just seem to rapidly loose power. Eventually it just cut out almost instantly - so I thought it felt electrical rather than fuel starvation.


Mike

Locked