Temp gauge sender - linear resistance?

An alchemy of sparks, copper wire and earth

Moderators: User administrators, Moderators

Post Reply
User avatar
T25Convert
Posts: 362
Joined: 20 Jun 2009, 09:27
80-90 Mem No: 7819
Location: Chester

Temp gauge sender - linear resistance?

Post by T25Convert »

New temperature gauge sender fitted to 1.9wbx. Black square plug one identical to the one on there.

However, temperature gauge now sits at 3/4 rather than the led. When it gets to fan cutting in it’s right at the hot end.

Whilst it’s only an indication it keeps making me nervous when I glance down to check it!

Does anyone know is the resistance approximately linear - I.e. could I fit a resistor to make it sit in a less hot position, without running the risk of it not reading really hot if it needed to?

Before anyone asks, it is electrical and not a cooling fault caused by fitting the sender!

Cheers
RIP - George - 1.9DG '85 AutoSleeper Trident - rusted away

George Second - 1.9DG '89 Caravelle

User avatar
AngeloEvs
Posts: 1096
Joined: 22 Nov 2007, 19:22
80-90 Mem No: 4709
Location: Upwell, Norfolk

Re: Temp gauge sender - linear resistance?

Post by AngeloEvs »

A resistor would have to be placed in series which is not an ideal solution. The resistance of the sender should be around 100 ohms for the gauge to sit left of the LED. Did you lose coolant when you replaced the sender?
1987 DG Karisma LPG with remodelled interior

User avatar
T25Convert
Posts: 362
Joined: 20 Jun 2009, 09:27
80-90 Mem No: 7819
Location: Chester

Re: Temp gauge sender - linear resistance?

Post by T25Convert »

AngeloEvs wrote:A resistor would have to be placed in series which is not an ideal solution. The resistance of the sender should be around 100 ohms for the gauge to sit left of the LED. Did you lose coolant when you replaced the sender?

I lost a fair amount of coolant, but have replaced it and also bled the system.

All bleed valves spout water as soon as they are opened. Heater blows hot. No evidence of any airlock. Fan used to come on when gauge reached around 3/4s, but now gauge reads 3/4 all the time and fan comes on when it reaches 'hot' on the gauge. So from a coolant system point of view it is all working as it should, hence my belief that the sensor resistance is just different to the old one.

For an electrical numpty, why would a resister in series not be ideal? I had just assumed that the sender was a thermistor and as such just adding a second resistor would 'correct' the resistance? Too simple?
RIP - George - 1.9DG '85 AutoSleeper Trident - rusted away

George Second - 1.9DG '89 Caravelle

User avatar
AngeloEvs
Posts: 1096
Joined: 22 Nov 2007, 19:22
80-90 Mem No: 4709
Location: Upwell, Norfolk

Re: Temp gauge sender - linear resistance?

Post by AngeloEvs »

The ideal solution would be to have the temp gauge working normally by establishing if the sender is the problem. I would remove it and heat it up by suspending it in a pan of water and bring it to boiling point. The resistance as you get to boiling point should be around 100 ohms. If it is much less, i.e., 60 to 80 ohms then en the sender is incorrect and needs replacing with the correct type.

You could insert a resistor but you need to measure the resistance of the temp sender at normal engine temperature and then add a resistor value that will make the combined resistance with the sender to 100ohms or thereabouts.

The resistor will need to be a 2W type or 3W, 5W. Alternatively, you could insert a wire wound potentiometer that has a value of 100ohms and then adjust it to have the Needle close to the LED at normal engine temps.
1987 DG Karisma LPG with remodelled interior

User avatar
T25Convert
Posts: 362
Joined: 20 Jun 2009, 09:27
80-90 Mem No: 7819
Location: Chester

Re: Temp gauge sender - linear resistance?

Post by T25Convert »

AngeloEvs wrote:The ideal solution would be to have the temp gauge working normally by establishing if the sender is the problem. I would remove it and heat it up by suspending it in a pan of water and bring it to boiling point. The resistance as you get to boiling point should be around 100 ohms. If it is much less, i.e., 60 to 80 ohms then en the sender is incorrect and needs replacing with the correct type.

Reluctant to pull it out and have to bleed it all again, but I did run it up to temperature and its reading around 60-65 ohms. In terms of replacing with the correct part, this was listed as being the correct part from a reputable supplier.

Like the idea of a potentiometer to dial it in, but looking at wire wound 2W+ ones suggests they'll be more than I paid for the sender, so might be better off just ordering another one and seeing if its any better!

Thanks for the help, much appreciated.
RIP - George - 1.9DG '85 AutoSleeper Trident - rusted away

George Second - 1.9DG '89 Caravelle

User avatar
AngeloEvs
Posts: 1096
Joined: 22 Nov 2007, 19:22
80-90 Mem No: 4709
Location: Upwell, Norfolk

Re: Temp gauge sender - linear resistance?

Post by AngeloEvs »

A 33 ohm 2W resistor should only cost around £1-50 for a pack of 5 from an EBAY supplier.

Who supplied the temp sender? Might be worth contacting them and describe the problem as your temp sender resistance reading is too low for an engine at normal temperature. If the engine was overheating then the rad fan would be kicking in but, from what you describe, the temp gauge needle is three quarters but the rad fan remains off.
1987 DG Karisma LPG with remodelled interior

WillScott
Posts: 17
Joined: 17 Nov 2018, 00:34
80-90 Mem No: 16780
Location: Preston

Re: Temp gauge sender - linear resistance?

Post by WillScott »

Hi there, I have exactly the same problem, brand new sensor now showing 3/4 and keep bottling out of leaving it till the fan cuts in. I'm planning on swapping the old one back in. What did you end up doing.
Will Scott
1989 Autosleeper Trooper
1.9 DG WBX 4 speed manual

Post Reply