New fuel pump but still no fuel to carb

Big lumps of metals and spanners. Including servicing and fluids.

Moderators: User administrators, Moderators

Post Reply
clifford coates
Posts: 35
Joined: 03 Jun 2009, 20:03
80-90 Mem No: 7919
Location: Colne Engaine, Essex

New fuel pump but still no fuel to carb

Post by clifford coates »

1987 1.9 DG automatic.
Wouldn't start unless fuel put down carb. So changed fuel filter and fuel pump and rod (Brikwerks £25). Still had to add fuel to carb but assumed cos filter changed etc. Drove 10 miles but when restarted engine cut out after a less than a minute. Still no fuel to carb. Sucked inlet hose and got mouthful of petrol. Took off outlet hose and turned engine and no fuel. Put back old pump trying both old and new rods. Still no fuel. Rod does go up and down but not by very much and was wondering if lack of movement would mean not enough push to pump? As I said it drive for ten miles. At a loss. Any suggestions? Many thanks.

Sent from my moto g(6) play using Tapatalk

1987 1.9 DG Auto (WIP)

mtpa
Posts: 7
Joined: 04 Jun 2008, 19:08

Re: New fuel pump but still no fuel to carb

Post by mtpa »

Hi all, many thanks to all the regulars for there information and advice. I don't post often as I know very little compared to you but have you checked the little cone filter in the carb inlet? It can be removed carefully with an appropriate sized screw.
Regards
Jed

Sent from my HTC U11 life using Tapatalk


mtpa
Posts: 7
Joined: 04 Jun 2008, 19:08

Re: New fuel pump but still no fuel to carb

Post by mtpa »

Their, bloody auto correct!!?

Sent from my HTC U11 life using Tapatalk


clifford coates
Posts: 35
Joined: 03 Jun 2009, 20:03
80-90 Mem No: 7919
Location: Colne Engaine, Essex

Re: New fuel pump but still no fuel to carb

Post by clifford coates »

mtpa wrote:Hi all, many thanks to all the regulars for there information and advice. I don't post often as I know very little compared to you but have you checked the little cone filter in the carb inlet? It can be removed carefully with an appropriate sized screw.
Regards
Jed

Sent from my HTC U11 life using Tapatalk
Many thanks. No cone in there. But no fuel coming out the pump anyway.

Sent from my moto g(6) play using Tapatalk

1987 1.9 DG Auto (WIP)

clifford coates
Posts: 35
Joined: 03 Jun 2009, 20:03
80-90 Mem No: 7919
Location: Colne Engaine, Essex

Re: New fuel pump but still no fuel to carb

Post by clifford coates »

Solved: weeping fuel line to pump; could suck petrol but the weeping fuel line was to much for pump. Noticed by recovery man when lower van - petrol started to leak from pipe. Thank you for everyone's help.

Sent from my moto g(6) play using Tapatalk

1987 1.9 DG Auto (WIP)

User avatar
Mocki
Membership Admin
Posts: 15275
Joined: 29 Sep 2005, 09:27
80-90 Mem No: 428
Location: Mansfield tel/txt 07947137911
Contact:

Re: New fuel pump but still no fuel to carb

Post by Mocki »

thanks for concluding the thread......
it makes much more sense when others find it in time to come if its got a conclusion 

so you are changing all your rubber fuel lines now as well then?
( the hard plastic wont need doing unless its visually damaged )
 
Steve
tel / txt 07947137911
Image
just one shade of very fast grey
________________

1989 2.1LpgWBX HiTop Leisuredrive Camper

Funkychops
Posts: 19
Joined: 01 Jul 2020, 15:39
80-90 Mem No: 0

Re: New fuel pump but still no fuel to carb

Post by Funkychops »

(please check your other fuel lines...)
1983 2L Air Cooled (CU) T25 Hightop
Based in Bristol

Post Reply