new engine still giving me grief

Big lumps of metals and spanners. Including servicing and fluids.

Moderators: User administrators, Moderators

Post Reply
User avatar
123-jn
Posts: 588
Joined: 28 Mar 2013, 19:50
80-90 Mem No: 12161
Location: Bromsgrove Worcstershire

new engine still giving me grief

Post by 123-jn »

I had her running this morning started fine apart from a lazy tappet which soon pumped up a bit and wentr off to ALDI 5 miles away no problems until on the way back she was slightly unwilling to accelerate a couple of times and the tickover bacame a bit uneven. I left her for the day until this evening when my wife and I were about to nhead off on a picnic. She would not tickover , she was running terribly so I held the tickover up for a bit to see if she would settle down,, I let her tickover very unevenly and we stood watching the engine shake on its mounts, but then all of a sudden she was running ok? so we set off but no sooner had we got round the corner suddenly we were back to square one and now with backfires, I tried petrol but now we had pinging as well so back to gas and we managed to get up the drive. I checked the tappets and apart from inlet in cylinder 1 being very slightly soft all was ok?
I started her up again all was fine for about 5 seconds and then all went again. Plugs all ok gaps all 0.7 (which I have always run on.) Could this be ignition related? could it be the amplifier or the coil?
123-jn Autohomes Komet 2.1 DJ AUTO 1989 (closed loop LPG pierburg 2E3)
- Citroen C4 Picasso 1.6 HDi

User avatar
itchyfeet
Posts: 12366
Joined: 23 Jul 2007, 17:24
80-90 Mem No: 12733
Location: South Hampshire

Re: new engine still giving me grief

Post by itchyfeet »

I'd suspect those tappets first, do a compression check.
1988 DG WBX LPG Tin Top
1989 DJ digijet WBX Holdsworth Villa 3 Pop Top
itchylinks

User avatar
itchyfeet
Posts: 12366
Joined: 23 Jul 2007, 17:24
80-90 Mem No: 12733
Location: South Hampshire

Re: new engine still giving me grief

Post by itchyfeet »

Mine was rough this moring after being parked in a field in the wind with fine rain, I think the ignition system was wet, got better as it dried out, fine now.
1988 DG WBX LPG Tin Top
1989 DJ digijet WBX Holdsworth Villa 3 Pop Top
itchylinks

User avatar
123-jn
Posts: 588
Joined: 28 Mar 2013, 19:50
80-90 Mem No: 12161
Location: Bromsgrove Worcstershire

Re: new engine still giving me grief

Post by 123-jn »

Tried a compression test but my tester seems to be playing up may have to try an old fashioned one thumb over the plug hole!! Also why would the tappets work ok one minute and then suddenly not work ?
123-jn Autohomes Komet 2.1 DJ AUTO 1989 (closed loop LPG pierburg 2E3)
- Citroen C4 Picasso 1.6 HDi

User avatar
123-jn
Posts: 588
Joined: 28 Mar 2013, 19:50
80-90 Mem No: 12161
Location: Bromsgrove Worcstershire

Re: new engine still giving me grief

Post by 123-jn »

When I say playing up I got 1. 0psi
2. 25psi
3. 0psi
4 50psi

I can't believe it would actually have got me to Aldi like that when you consider it was actually running nice and even no movement from the engine all four firing no issues until we tried to go out tonight. As I understand it in order for there to be no compression the valves would need to be being held open by the tappets, Ie the tappets would have to be too tight? Now I could understand that after I had re adjusted them as the process may have held some valves open by 3 half turns but not before as she has been running fine after I last set them?

At present there is not much compression but with these tappets I would expect that until she starts up and they adjust after my readjustment. Problem at present is she isn't going to do that!!!
Last edited by 123-jn on 10 Jul 2016, 20:38, edited 1 time in total.
123-jn Autohomes Komet 2.1 DJ AUTO 1989 (closed loop LPG pierburg 2E3)
- Citroen C4 Picasso 1.6 HDi

User avatar
itchyfeet
Posts: 12366
Joined: 23 Jul 2007, 17:24
80-90 Mem No: 12733
Location: South Hampshire

Re: new engine still giving me grief

Post by itchyfeet »

no if valves don't open you get low compression.
1988 DG WBX LPG Tin Top
1989 DJ digijet WBX Holdsworth Villa 3 Pop Top
itchylinks

User avatar
123-jn
Posts: 588
Joined: 28 Mar 2013, 19:50
80-90 Mem No: 12161
Location: Bromsgrove Worcstershire

Re: new engine still giving me grief

Post by 123-jn »

Just turned the engine over by hand, All valves are opening and closing as far as I can see so none of the tappets are that bad at present. It doesnt look Like any are being held open but that is more difficult to see. It's pretty rough that you rebuild and engine but you can't rely on the new parts enough to rule out issues isn't it!!! I think I may reset all the tappets again tomorrow just to make sure and replace the coil and ign amp before trying again. I wonder if Euro carparts would stock them?
123-jn Autohomes Komet 2.1 DJ AUTO 1989 (closed loop LPG pierburg 2E3)
- Citroen C4 Picasso 1.6 HDi

User avatar
itchyfeet
Posts: 12366
Joined: 23 Jul 2007, 17:24
80-90 Mem No: 12733
Location: South Hampshire

Re: new engine still giving me grief

Post by itchyfeet »

or GSF.
1988 DG WBX LPG Tin Top
1989 DJ digijet WBX Holdsworth Villa 3 Pop Top
itchylinks

weegaz22
Posts: 253
Joined: 12 May 2016, 21:30
80-90 Mem No: 15325
Location: Glasgow

Re: new engine still giving me grief

Post by weegaz22 »

Do you have a compressor you could connect your comp tester to? or run it on another vehicle that has no issues to rule it out? those figures are kind suspect to me given that you got it all the way to aldi's

Whats the story behind the new engine?, was it just a block? or did it come with all the ancillaries? carbs etc, what happened to the old engine? was it doing similar symptoms?
1989 LHD Westfalia Multivan 1.9TD AAZ

California Dreamin
Posts: 2672
Joined: 03 Apr 2007, 12:54
80-90 Mem No: 8386
Location: Nottingham

Re: new engine still giving me grief

Post by California Dreamin »

I think you are looking in the wrong area....like you say, it was running on all four, then in a instance running on two, 'engine rocking on its mounts'. Sounds like an ignition problem....Personally I would be suspecting the metal spark plug cap 'shrouds' which can cause intermittent arcing and so none function of one or more cylinders.
These metal shrouds can be 'cut off' with tin snips without any detriment to the engines running as their function is ONLY to cut down radio interference.

Compression doesn't just come and go although I do accept that you can loose compression (after tappet pre-sets are carried out) until they bleed off a little and settle.
Also worth looking at the vacuum take off (vacuum leak) which can loose cylinders on that bank.
Also...what is the choke flap doing? bi-metal spring 'pig tail ends' break off leading to the choke flap randomly closing.

Martin
1989 California 2.1MV

User avatar
123-jn
Posts: 588
Joined: 28 Mar 2013, 19:50
80-90 Mem No: 12161
Location: Bromsgrove Worcstershire

Re: new engine still giving me grief

Post by 123-jn »

No this engine has been lovingly rebuilt by me as a 2.1 new bearings, rings, valves and guides and suprisingly tappets!!! When it was running it sounded great!!! The compression tester has not been used for a long time and it is a cheapie Am-Tech one but having now reset the tappets just to make sure there will be very little compression until the engine starts and the oil pressure does it's stuff with the tappets. I am getting 85PSI cold oil pressure and 25 PSI hot at tickover. When running along at 50mph I am getting 60PSI so at least that is OK!!! Water Temp was running at 90 -105degrees and oil temperature was running at 90 - 115 except when I was on the motorway when it went up to 122 degrees!!! And that is with a 19 row cooler!!
123-jn Autohomes Komet 2.1 DJ AUTO 1989 (closed loop LPG pierburg 2E3)
- Citroen C4 Picasso 1.6 HDi

User avatar
123-jn
Posts: 588
Joined: 28 Mar 2013, 19:50
80-90 Mem No: 12161
Location: Bromsgrove Worcstershire

Re: new engine still giving me grief

Post by 123-jn »

Thanks for the help California Dreamin, I have had shroud trouble before with the old 1.9 but after a lead change this was ok, used to be quite pretty at night but did not cause this level of misfire. I am thinking coil or amplifier as my next move but have not considered the choke as a cause I must admit. I will have a look down the backfire flap and see if it is as it should be.

These tappets I have are a new set of Kolbenshmidt from BW but they are taking a while to wear in, They bleed down really quickly especially when the valve spring is pushing on them, This means you always have a rattle on start up, This goes very quickly within half a mile and they become reasonably quiet except for one one them which I cant locate yet which still taps a bit. I hope they get better with age!!!
123-jn Autohomes Komet 2.1 DJ AUTO 1989 (closed loop LPG pierburg 2E3)
- Citroen C4 Picasso 1.6 HDi

California Dreamin
Posts: 2672
Joined: 03 Apr 2007, 12:54
80-90 Mem No: 8386
Location: Nottingham

Re: new engine still giving me grief

Post by California Dreamin »

Coils and ignition amplifiers tend to fail hot. I wish you well with your quest.

Martin
1989 California 2.1MV

tobydog
Posts: 791
Joined: 07 Mar 2009, 21:03
80-90 Mem No: 6484
Location: Near Saarfend, Essex

Re: new engine still giving me grief

Post by tobydog »

Water/crap in carbs?
Knowledge is power
1970 CU

User avatar
Mocki
Membership Admin
Posts: 14789
Joined: 29 Sep 2005, 09:27
80-90 Mem No: 428
Location: Mansfield tel/txt 07947137911
Contact:

Re: new engine still giving me grief

Post by Mocki »

tobydog wrote:Water/crap in carbs?

is that a cure or a symptom? if the former, how often?? lol :run
Steve
tel / txt 07947137911
Image
just one shade of very fast grey
________________

1989 2.1LpgWBX HiTop Leisuredrive Camper

Post Reply