Sticking kickdown arm on 2.1 Auto - HELP!!!!

Big lumps of metals and spanners.

Moderators: Moderators, User administrators

Locked
poshbuggers
Posts: 1353
Joined: 23 Oct 2005, 19:15
80-90 Mem No: 0
Location: Nottinghamshire

Sticking kickdown arm on 2.1 Auto - HELP!!!!

Post by poshbuggers »

Had this problem since I bought the van but now its getting worse to the point I dare not drive it.

Throttle seems to stick on at 1/2 pedal travel. Its not the pedal end or the throttle body (cleaned and lubricated both) but somewhere between.

Bought a new (short) cable to fit in the hope that will sort it.
Last edited by poshbuggers on 04 Aug 2006, 18:01, edited 1 time in total.

'90 Syncro Hightop. Ex-BUPA/Rowan ambulance with 2.0L GTI power and some curious windows.
)

User avatar
Arvi
Posts: 243
Joined: 22 Dec 2005, 14:59
80-90 Mem No: 2472
Location: Birmingham KingsHeath
Contact:

cable

Post by Arvi »

when i bought my van i had similar prob i just changed the full cables length and a linkage by the pedal was not expensive did the trick also notied that my cable was kinked which did not help
Now running and fixing
1990 VW Caravelle GL 2.1 auto

poshbuggers
Posts: 1353
Joined: 23 Oct 2005, 19:15
80-90 Mem No: 0
Location: Nottinghamshire

Post by poshbuggers »

So is it a 2 piece cable setup (haven't got a manual for it) with a break partway then?

Think what I have is the rear section but thats all I was supplied with when I asked for the accelerator cable.

'90 Syncro Hightop. Ex-BUPA/Rowan ambulance with 2.0L GTI power and some curious windows.
)

OLD ONE
Posts: 567
Joined: 27 Jun 2006, 10:38
80-90 Mem No: 1737
Location: ESSEX

Dangerous sticking throttle on 2.1 Auto

Post by OLD ONE »

My one is not Auto, but had same prob when I first got the van. 2.1 injection. It turned out to be a link between cable and injection unit jamming on a bunch of wires. 1 cable tie, job done
Health has now stopped me camping Etc.

poshbuggers
Posts: 1353
Joined: 23 Oct 2005, 19:15
80-90 Mem No: 0
Location: Nottinghamshire

Post by poshbuggers »

I've cleaned and checked the linkage from throttle body back and isolated the problem to a sticking link bar which joins the throttle linkage to the cable.

Its something to do with the kickdown I reckon, but it jams partway of full travel and doesn't release till forced (i.e. spring action is not enough).

Tried some lubricant but not really helped much.

Could it be the transmission fluid is low? How do I know the correct level on the stick?

Any other ideas what can be done to free this troublesome thing?

'90 Syncro Hightop. Ex-BUPA/Rowan ambulance with 2.0L GTI power and some curious windows.
)

Locked