White smoke.... help

for questions and answers about alternative power transplants on the T25, GTi, Porsche,Subaru etc, this is the place. You must register to post but anyone can read.

Moderators: User administrators, Moderators

Post Reply
Bobreoc
Posts: 52
Joined: 24 May 2018, 19:56
80-90 Mem No: 0
Location: Redditch.

White smoke.... help

Post by Bobreoc »

Morning all.

I had a 1z running as a mtdi. The engine was toast when the crank pulley let go, I struggled to source a replacement and ended up buying an ahu that supposedly a runner. (Knew I should of bought a running car)

Anyway swapped everything over changed the cambelt and water and put it in the van (it’s running a land rover injection pump to. First problem was all 4 glow plugs were toast so replaced them. Started the engine and it sounded ok but plumed white smoke and I mean a lot. I re checked the timing of the pump
Which I believe is good so started the van and still plumed white smoke... I’m now changing the injectors (can’t for seem to remove number two though even with a puller) as the old engine before it let go ram great.

If it’s not the injectors I’m pretty much stumped to what it could be after that, any thoughts or help... could it be turbo?

(Side note, the oil pressure light was constantly on and buzzer so swapped the oil pressure switch from the old to so I’m hoping it’s just the switch)

User avatar
ZsZ
Posts: 736
Joined: 12 Feb 2009, 16:28
80-90 Mem No: 14899
Location: Budapest, Hungary
Contact:

Re: White smoke.... help

Post by ZsZ »

white smoke can be unburnt diesel or coolant. The smell is different.
Unburnt fuel is usually symptom of bad timing or bad injectors. Injectors can stuck if they are left dry for long time.
LR pump should be around 1.4mm (no EGR pump) or 1.54mm (EGR pump) lift @TDC
If swapping injectors not helps I would make a leak down test to check if pressure going to the coolant circuit.
Zoltan
1986 Multivan ex-Caravelle. Van since 2006, running mTDi 1Z since 2008 with Fiat Croma 1.9 TDid pump 2008-2019, custom pump since 2019
5spd custom box 4.57 diff + 0.74 5th

davidoft1
Posts: 1171
Joined: 27 May 2009, 18:56
80-90 Mem No: 16628
Location: hayling island

Re: White smoke.... help

Post by davidoft1 »

Some oil lights on diesel work in reverse

How long had the engine sat ? Injectors and fuel pumps rust pretty quickly resulting in them all needing a rebuild , was the pump on the engine ?

Bobreoc
Posts: 52
Joined: 24 May 2018, 19:56
80-90 Mem No: 0
Location: Redditch.

Re: White smoke.... help

Post by Bobreoc »

ZsZ wrote:white smoke can be unburnt diesel or coolant. The smell is different.
Unburnt fuel is usually symptom of bad timing or bad injectors. Injectors can stuck if they are left dry for long time.
LR pump should be around 1.4mm (no EGR pump) or 1.54mm (EGR pump) lift @TDC
If swapping injectors not helps I would make a leak down test to check if pressure going to the coolant circuit.

Thank you, I managed to remove all but one injector. Gave up in the end on number 2 injector and refitted the 3 known good ones to see if that made a change..... exactly the same but sounds like it’s missing. Tonight I’ll re do the pump timing. I think I had it set up 1.2mm originally.
I really need to get number 2 injector free though as that could be my issue possibly.

It does smell like diesel so assuming it’s diesel.

Bobreoc
Posts: 52
Joined: 24 May 2018, 19:56
80-90 Mem No: 0
Location: Redditch.

Re: White smoke.... help

Post by Bobreoc »

davidoft1 wrote:Some oil lights on diesel work in reverse

How long had the engine sat ? Injectors and fuel pumps rust pretty quickly resulting in them all needing a rebuild , was the pump on the engine ?

I’ve swapped the switch and the light is still on.. which is worrying.
The engine I’ve been told was only sat for 6 months.. do I believe that now? Not a chance, alsp was it removed because it’s nakered. Quite possibly.
The LR pump was off my old engine so I know it’s good

Bobreoc
Posts: 52
Joined: 24 May 2018, 19:56
80-90 Mem No: 0
Location: Redditch.

Re: White smoke.... help

Post by Bobreoc »

Do I have change the oil pump or oil pick up on the conversion? I’ve used the jx sump

Post Reply